MAGNET Project: Scheduling and Map view tutorial

This tutorial will guide you through the main functions of scheduling and the Map view using a sample project.

The tutorial includes downloadable sample files located at the end of the article.

Step 1: Create a new project

  1. Create a new project from template (File > New from template).
  2. Select the default template file.
  3. Navigate to Project > Project Properties to set the project time. 
  4. Make the project start time June 21, 2021, and the deadline October 31, 2021.
  5. Leave the other values as they are, and click OK.

Step 2: Import quantities

A bill of materials can be imported from a Microsoft Excel file. You will now import one containing masses for a road line that is to be constructed.

  1. Take a look at the ScheduleBOQ.xlsx file (located at the bottom of the article) before importing. Then import the bill of quantities into your project.
  2. Navigate to File > Import.
  3. Select ScheduleBOQ.xlsx, and click Open.
  4. In the import dialog box, click Next and then Import.

The imported task quantities appear in the mass diagram. Cut masses are above the road line, and fill masses are below it.

      Step 3: Import background map

      One or several PDF maps of the project can be imported to the background. Next we are going to import a background map with two coordinate points. (Observe the crosses marking coordinates in the lower right corner and on the left side). 

      1. Navigate to Home > Views > Map view.
      2. Add a background map by going to Insert > Graphics > Image.
      3. Select Schedule_Tutorial_Map.pdf (located at the end of the article), and click Open.

      The coordinate points are marked with small colored circles and crosses which you see when you zoom closer. 

      1. Use the zoom sliders for each marker to zoom closer and set a more accurate position for the red and blue markers.
      2. First select the blue marker icon, and click on the center of the blue coordinate point. Write the blue marker coordinates in their fields on the right (X = 4430000,Y = 6785200).
      3. Then select the red marker icon located in the Image tab, and click on the center of the red marker coordinate point. Then write the red marker coordinates on the right (X = 4430600,Y = 6786000).
      4. Once the coordinates are set, click OK.

          Step 4: Draw a road line, and create a disposal area in Map view

          Stations in this project run from 43,000 to 43,900, and they are marked on the map. To zoom in/out of the view, click on the map to activate the view, then hold down Ctrl and scroll the mouse.

          Draw a road line starting from station 43 000 until station 43 900.

          1. Go to Insert > Location.
          2. Select the green point in the map at station 43 000, and continue drawing a line until you have reached station 43 900. Each click adds a coordinate point for the road line.
          3. Double-click on the green dot located at the end station to stop drawing.
          4. The Select location dialog box appears. Select Use existing location and Main road line to define the location of the road line. If the coordinates of the drawn road line are incorrect, you can modify the station numbers in the Change coordinate station span prompt.

          Next we are going to draw a disposal area in the map view.

          1. Go to Insert > Location.
          2. Draw a polygon over the purple circle on the map by clicking the points where you would like the corners of the disposal area to be located.
          3. Double-click to stop drawing.
          4. The Select location dialog box opens. Select Create new location to create a new location for the disposal area.
          5. Double-click on the created disposal area polygon, and change the name to Disposal area.

          Step 5: Create a road connection (intersection) in Map view

          1. Navigate to the Graphics window in Map view and move Main road line on top of the PDF map by dragging Main road line on top.
          1. Draw a road connection from the disposal area to the main road line.
          2. Go to Insert > Intersection
          3. Click on the disposal area, and draw the intersection line to the main road line.
          4. Right-click to stop drawing.
          5. Click on the intersection connection to edit the Intersection Properties dialog box. Set Length: 420, and click OK.

          This means that there is a 420-meter long intersection (i.e., connection) between the main road line station 43,000 and the disposal area’s center of mass. (The disposal area is on an area without stations). The length you set should not be the beeline distance between the points but the actual distance that needs to be driven when hauling mass, including any detours. By default, the program calculates the distance as the crow flies.

          Step 6: Define the disposal area, and create a quantity for paving in Mass haul view

          Define the disposal area quantity and capacity by creating a new quantity and editing the quantity properties.

          1. Navigate to Insert > Quantity. Create a new quantity for the disposal area with the following properties:
            • Name: Disposal area
            • Quantity type: Disposal
            • Maximize usage: No
            • Total amount: 8000
            • Location: Disposal area

          The disposal area quantity should have the Maximize usage unchecked so that the haul calculation knows that the disposal area should only be used when needed (i.e., in case of storing leftover mass). If Maximize usage is checked, the haul calculation will try to fill the disposal quantity as if it was a normal fill quantity.

          Click OK. The quantity of disposable material that can be hauled to this disposal area is now 8,000 compacted cubic meters.

          1. Create a new quantity for Paving. Navigate to Insert > Quantity.
            • Name: Paving
            • Quantity type: Paving
            • Total amount: 10800
            • Location: Main road line

          Select the Quantities tab, and define the start and end stations (start station: 43 000, end station: 43 900), and click OK.

          All quantities have now been inserted in the project.

          Step 7: Create tasks from quantities in Mass haul view

          Next we are going to create tasks from quantities in Mass haul view.

          1. Select your bill of quantity (Schedule_BOQ) located under Bills of quantities.
          2. Right-click and select Create tasks from quantities.

          Tasks for all quantities have now been created, and tasks are visible in Gantt view.

            Step 8: Edit the schedule in Gantt View

            Task timings are being calculated automatically according to production rates assigned to quantity types. Task timing can be changed manually if there is no production rate applied to a task.

            1. Create a dependency from task Cut to task Rock Crushable.
            2. Draw a similar dependency between tasks Fill and Noisebank.
              • Create task dependencies by hovering over the task bar and dragging the moving arrow downwards to the beginning or end of the task you want to create a dependency with.
              • Release the mouse button to create the dependency. 

            You can see the bars have moved in the Gantt chart accordingly.

            1. Modify the disposal area task duration.
              • Double-click the task for Disposal area, and delete the resource type used for the task in the Resource types tab.
              • Right-click on the resource type row, and click Delete.

            In the Properties tab, change the task duration to 50 days.

              Step 9: View the schedule in Time-location view

              The Time-location view chart shows road line stations horizontally and time vertically.

              1. Navigate to Home > Views > Time-location view.

              In some cases, it might be better to start a cut or a fill from a high station instead of a low station.

              1. Change the start station for task Cut. Double-click line Cut, and edit Direction of work to High to low.
              2. Do the same for task Rock Crushable.
              3. Calculate hauls (Project > Calculate hauls).
              4. In Time-location view, click on Noisebank to view details of hauls in the Hauls window located at the bottom right corner of the screen.

              Step 10: View and present the schedule on a map

              Open Map view to see how the project schedule can be presented on a map of the project.

              The Date view can be changed from the toolbar located at the top of the screen. Now change it from 25/2021 through 33/2021, and study each week.

              1. The project starts at week 25, and mass is hauled from the cut on stations 43,000-43,470 to the fill on stations 43,490-43,670. Areas with active tasks are blue. You can move the mouse on top of them to see the location, task names, and quantities. Also the Disposal area is blue to show that it is ready to use.
              2. During week 26, mass is still hauled to the fill and then to the noisebank.
              3. During week 27, mass is hauled only from the cut to the noisebank.
              4. During week 28, after the cut is finished, the excavator crew moves on to the rock cut on stations 43,130-43,410. Mass is hauled from there to the noisebank and also to the disposal area. This is continued on weeks 29 and 30.
              5. During week 31, paving is started.
              6. During week 32, all tasks are finished.